Home » Windows » Internet » PumpKIN 2.7 – freeware

PumpKIN 2.7 – freeware

Welcome to this page, please consider trying the following software named “PumpKIN 2.7“, here is the concise language to describe its function or features – Open source, fully functional, free TFTP server and TFTP client.


With this program, you can: Open source free TFTP server TFTP client. and the below is its basic information:
  • License: Freeware
  • File Size: 143KB
  • Released date: 2006 3 1
  • Developer: PumpKIN 2.7
  • Suitable Platforms: Win 9x ME NT 2K XP 2K3
Developer’s description: PumpKIN 2.7 – Open source, fully functional, free TFTP server and TFTP client.
PumpKIN is an open source, fully functional, free TFTP server and TFTP client, which implements TFTP according to RFC1350. It also implements block size option, which allows transfer of files over 32MB, as well as transfer size and transfer timeout options described in RFC2348 and RFC2349.The primary use of PumpKIN is maintenance of the network equipment (such as router firmware upgrade) that fetches images from TFTP server, although it is also useful for transfering files between parties involved in a conversation over ntalk connection using our T42 software (it also detects ntalk conversation held over now obsolete program ¡äwintalk¡ä).Features:Fully standard-compliant TFTP file transferUnlimited simultaneous transfers both for TFTP server and clientSupport for TFTP blocksize option allows transfer of large files if both TFTP server and client support itConvenient GUICombines TFTP server and TFTP clientOriginally developed for Windows 95, it reportedly runs on all Win32 platforms: Windows 98, Windows NT, ME, XPCan run in background, taking up a 256 pixels of screen nicely packed as a 16×16 square in your notification tray areaOpen source for those willing to add missing features, fix bugs and examine code for potential flaws and funYou¡äre free to torture it the way you want to as long as you preserve original author¡äs credentialsNote that PumpKIN is not an FTP server, neither it is a FTP client, it is a TFTP server and TFTP client. TFTP is not FTP, these are different protocols. TFTP, unlike FTP, is used primarily for transferring files to and from the network equipment (e.g. your router, switch, hub, whatnot firmware upgrade or backup, or configuration backup and restore) that supports using of TFTP server for, not for general purpose serving downloadable files or retrieving files from the FTP servers around the world…. click here for more…

Check Also

Scanner Pro 7 – best iOS phone scanner software

Scanner Pro 7 – best iOS phone scanner software Scanner Pro by Readdle is excellent …

free cross-platform Markdown editor – Typora

Now a lot of software (such as Visual Studio Code, Leanote, DayOne, Simplenote, Atom, EverEdit) …

Top 10 photo editor for Windows worldwide

According to the most authoritative data from the world’s leading download site “Cnet”, We pick …